WordPress Downgrade Plugin

WordPress Downgrade Plugin

If for some reason you run into an issue when you upgraded WordPress, you can simply restore the backup that you made (you made one, right?)

If the issue is with WordPress core, and for example your theme does not (yet) support the new WordPress version, then it’s good to know there’s a downgrade plugin as well (there’s a plugin for everything nowadays!).

It seems that the most recent WP 5.5 version for example does not work too well with page builders, like Elementor and WP Bakery, so you might end up with a broken website and a lengthy restore process.

You can always call for help with your web hosting company also, they should also have a backup for you. But you can try downgrading to the previous version also. Do you remember which one? Don’t worry, a little bit further down this page, you get to select it from a list, maybe it’ll come back to mind.

Backup

Even before you begin with fixing your issue, please realize that your issue can always get worse. So make another backup. It’s better than nothing. Not every hosting company makes backups for you, and even if they do, you should always make your own backups, just in case.

Restore WP Core

Your only 2 minutes away from restoring to an older WordPress version. Follow these steps after you created a backup.

1. Install the plugin

Search for “wp downgrade” where you add the new plugin. This is generally /wp-admin/plugin-install.php?s=wp-downgrade&tab=search&type=term — click “Install Now”, then “Activate”.

2. Set the old version + Save

Go to the plugin settings page, you can find the settings link from the Plugins page. You can find the correct version number on the releases page (1). Copy it to the field (2), and “Save Changes” (3). Then Click “Up-/Downgrade Core” (4). See screenshot.

3. Start the process by clicking “Re-install Now”

I hope all went well!

Posted in: Blog

Leave a Comment (0) ↓